What are MindMeister's System Requirements?

You can use MindMeister from any internet-connected device that meets the following requirements:

  • Minimum 1GB memory
  • Scroll mouse or touchpad or touchscreen
  • Email address

 

Supported browsers are:

 

  • Mac:

- Google Chrome (66 and above)

- Mozilla Firefox (7 and above)

- Safari (5 and above)

- Opera

 

  • Windows:

- Google Chrome (66 and above)

- Mozilla Firefox (7 and above)

- Opera

- Internet Explorer 11

- Microsoft Edge

 

Note: We don’t support any Operating Systems that don't have the “DigiCert Global Root G2" root certificate.